Some users unable to receive email on Premium Business Email platform
Incident Report for Liquid Web - Cloud Sites
Resolved
This incident has been resolved.
Posted May 19, 2022 - 11:43 CDT
Identified
Rackspace is aware that some users are unable to receive emails on our hosted email platform. Engineers have identified the problem and are working on the fix.
Posted May 15, 2022 - 12:07 CDT