Cloud Sites Support Inbound Number Issues
Incident Report for Liquid Web - Cloud Sites
Resolved
The issue we had been experiencing with (855) 348-9060 has been resolved. Thank you for your patience and we apologize for any inconvenience this may have caused.
Posted Oct 22, 2019 - 22:53 CDT
Identified
The issue has been identified and the 1(855)348-9060 number is now functional to call. We are still investigating a few other lines in but the direct line mentioned above and our standard Liquid Web phone line are available to be used.
Posted Oct 22, 2019 - 16:21 CDT
Investigating
We are currently experiencing issues with the direct inbound Cloud Sites Support phone number - 1(855)348-9060. Our teams are working to identify and resolve the issue.

In the meantime, please call us at our main LiquidWeb line 1(800)580-4985, then 2 for Support, and 3 for Cloud Sites. Thank you for your patience while we work to get this resolved.
Posted Oct 22, 2019 - 09:56 CDT